Ubuntu On Sony Vaio FW Series

Tips & Tricks related to Sony Vaio FW series laptops

Posts Tagged ‘Vaio

12.04 Precise Pangolin on Vaio FW

with 6 comments

CE-THD_assoc_300x250

 

Updated some time ago. Moved back to Unity from Gnome Shell (there was bugs in Unity in previous releases). Brightness and keys works correctly.

And some time ago I moved from fglrx drivers to open-source drivers. Now hd video works pretty good, no glitches in Unity compizing.

A while ago I did a hardware DIY upgrade, I added SSD to existing HDD, so I now have 2 drives installed. SSD for fast loading and slow apps like Java, Eclipse etc. Pretty fast now.

I will defenetly make a post about SSD+HDD upgrade with pictures in near feature =)

Written by egaistek

May 28, 2012 at 21:56

Posted in Vaio

Tagged with , , , , , , , , ,

Video: Ati Mobility Radeon HD 3470

with 6 comments

I have Mobility Radeon HD 3470 on my FW11ER laptop.

I’m on Ubuntu Intrepid alpha 4 now and while there is new X server, the official drivers from Ati desn’t work (this bug is already reported).

I have luck with installing radeonhd video driver, but it still have no 3D acceleration support with 2D at the same time, but for my work it’s just fine. Anyway it’s better than “ati” driver used by default in Intrepid. You need to compile version from git repository because 1.2.1 is not working, there is a bug with display detection.

You need this packages installed to be able compile it: build-essential, autoconf, autogen, automake, automake1.7, autotools-dev, xorg-dev, x11proto-dri2-dev, x11proto-xf86dri-dev, xserver-xorg-dev, mesa-common-dev and maybe some more =)

There is a guide about compilling and installation of radeonhd on x.org wiki.

Once you checkout git repository, the guide says that you need to configure before compiling with this command: ./autogen.sh, but for Ubuntu you need do it like this:
./autogen.sh --prefix /usr --libdir /usr/lib
make
sudo make install

Thats all at the moment, video is working.

UPD: The list of developer packaged needed before compiling:
libdrm-dev
libgl1-mesa-dev
libgl1-mesa-dri
x11proto-gl-dev
x11proto-xf86dri-dev
xserver-xorg-dev
autotools-dev
xorg-dev
libtool
automake
autoconf
pciutils-dev
libz-dev
zlib1-dev

Written by egaistek

September 8, 2008 at 20:34

Posted in Vaio

Tagged with , , , , ,

The System

with 7 comments

Ok here is a start. I’m running Ubuntu Interipid Alpha 4 on Sony Vaio VGN-FW11ER laptop.

After clean installation i’ve got:

Video Ati: yes without acceleration (movies are slow)

Audio Realtek:yes

Wireless Atheros: not work at all

Bluetooth: yes

Ethernet: yes

Touchpad: yes

Wireless switch: yes

Keys

S1: doing nothing (dunno work or not)

Vol -/+: yes

Play/Pause, Stop, Rewind: yes

AV Mode: doing nothing

Fn Keys

Fn+F4 (Mute): yes

Fn+F5/F6 (Brightness): no =(

And any others: no

Written by egaistek

September 8, 2008 at 20:27

Posted in Vaio

Tagged with , ,