Ubuntu On Sony Vaio FW Series

Tips & Tricks related to Sony Vaio FW series laptops

Intrepid beta and fglrx

with 4 comments

Following this comment I have updated my Intrepid installation on another partition to beta.

Well I still have no 3D. Fglrx is working in testing mode (square AMD logo with crossed “3D” in bottom right corner with “Testing use only Unsupported hardware” text on it)

Then I have checked xorg logs and found this:

(WW) Falling back to old probe method for fglrx
(II) ATI Proprietary Linux Driver Version Identifier:8.54.3
(II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.543.2
(II) ATI Proprietary Linux Driver Build Date: Oct 10 2008 21:37:39
(WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
(WW) Video driver ABI version of the X server is 4.1
(--) Assigning device section with no busID to primary device
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
(--) Chipset Supported AMD Graphics Processor (0x95C4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found

I guess I should test live cd then.

UPD: ok, I have forgot to install linux-headers for newer kernel, now I have logo in the corner without crossed “3D” with the same text. 3D works, compiz works.. but that annoying logo, and I have only 1000-1300 fps in glxgears, it should be faster.

Advertisements

Written by egaistek

October 16, 2008 at 14:40

Posted in Vaio

Tagged with ,

4 Responses

Subscribe to comments with RSS.

  1. How did you install the driver? I used the ‘Hardware Drivers’ app AKA Jockey. I get good performance but do see a big difference when running on AC or Battery. This is because of the settings in the ‘ATI Catalyst Control Center’ app. Maybe this is the difference.
    Here is the output from glxgears on my system. Please feel free to contact me if I can be of assistance.

    KWin – on AC
    21821 frames in 5.0 seconds = 4362.364 FPS
    13755 frames in 5.0 seconds = 2750.727 FPS
    15152 frames in 5.0 seconds = 3028.147 FPS
    19415 frames in 5.0 seconds = 3882.744 FPS
    11872 frames in 5.0 seconds = 2374.333 FPS
    19845 frames in 5.0 seconds = 3968.880 FPS
    16206 frames in 5.0 seconds = 3233.513 FPS

    Kwin – on Battery
    12638 frames in 5.0 seconds = 2527.387 FPS
    13198 frames in 5.0 seconds = 2639.424 FPS
    13074 frames in 5.0 seconds = 2614.672 FPS
    13268 frames in 5.0 seconds = 2653.431 FPS
    13506 frames in 5.0 seconds = 2699.853 FPS
    13064 frames in 5.0 seconds = 2608.534 FPS
    13188 frames in 5.0 seconds = 2637.558 FPS

    Compiz – on AC
    20564 frames in 5.0 seconds = 4112.677 FPS
    14223 frames in 5.0 seconds = 2844.599 FPS
    22158 frames in 5.0 seconds = 4431.494 FPS
    16917 frames in 5.0 seconds = 3383.338 FPS
    18118 frames in 5.0 seconds = 3623.581 FPS
    13506 frames in 5.0 seconds = 2701.116 FPS

    Compiz – on Battery
    14550 frames in 5.0 seconds = 2909.888 FPS
    14020 frames in 5.0 seconds = 2803.928 FPS
    14294 frames in 5.0 seconds = 2858.637 FPS
    13954 frames in 5.0 seconds = 2790.322 FPS

    Tamagotono

    October 20, 2008 at 12:06

  2. I have installed xorg-driver-fglrx I guess (maybe a typo).

    Do you have amd logo in the corner? and which version shows yours Ati catalist control center?

    egaistek

    October 20, 2008 at 15:40

  3. I do not have any sort of an AMD logo anywhere on my display.

    Under the information tab on the control center shows this info. (I am not sure if there is a difference but I am running Intrepid 64bit version)

    Driver Version 8.54.3
    Catalyst Control Center Version 2.1
    OpenGL Version 2.1.8087 Release

    If I force 4X anti-aliasing then when I run glxgears I am usually hanging around 800 – 900 FPS, other than that, I am not able to slow down my results that much with any other settings.

    Tamagotono

    October 21, 2008 at 04:56

  4. I have tried today a livecd of Intrepid RC and there is no fglrx loaded by default nor I can install it from Hardware drivers. Have you used it on beta?

    I have another laptop flying around which is IBM, and there is installed Ati video too (radeon mobile x100, I’m not sure), but this release candidate enabled compiz for that laptop and I guess it used fglrx.

    egaistek

    October 27, 2008 at 21:08


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: