Ubuntu On Sony Vaio FW Series

Tips & Tricks related to Sony Vaio FW series laptops

The System

with 7 comments

Ok here is a start. I’m running Ubuntu Interipid Alpha 4 on Sony Vaio VGN-FW11ER laptop.

After clean installation i’ve got:

Video Ati: yes without acceleration (movies are slow)

Audio Realtek:yes

Wireless Atheros: not work at all

Bluetooth: yes

Ethernet: yes

Touchpad: yes

Wireless switch: yes

Keys

S1: doing nothing (dunno work or not)

Vol -/+: yes

Play/Pause, Stop, Rewind: yes

AV Mode: doing nothing

Fn Keys

Fn+F4 (Mute): yes

Fn+F5/F6 (Brightness): no =(

And any others: no

Advertisements

Written by egaistek

September 8, 2008 at 20:27

Posted in Vaio

Tagged with , ,

7 Responses

Subscribe to comments with RSS.

  1. hi

    i’m a vaio sr user;
    if you want i can give some help to you to map birghtness on alt + f5, f6

    i’ve a question for you… does your internal microphone work?

    in the sr there is a realtek alc262, also in your laptop?

    thanks

    contact me by mail if you want

    Giovanni Pellerano

    September 12, 2008 at 01:44

  2. Giovanni Pellerano, yes i have ALC262 too. I have not tested microphone yet.

    Brightness control not work here at all, i can’t change it in power manager etc. If you have any clue it would be nice =)

    egaistek

    September 12, 2008 at 05:41

  3. Hi,

    I have a sony laptop VGN-FW170J I am disappointed. I installed kubuntu and rebooted to load the new OS. Along with Vista I saw KUbuntu, I selected kUbuntu a screen comes with” Kubuntu” after a while nothing appears on the screen, just blank.

    I followed alll the typical steps.

    Am I missing any driver?

    mak

    September 13, 2008 at 09:39

  4. Hi mak, maybe you should just wait for something to appear? If xserver isn’t load it should show you a failsafe dialog to select video drivers. But maybe Kubuntu have different thing, I have not tried it.

    Anyway, if kubuntu live cd works ok, then installed version should be ok too.
    Which version of kubuntu have you installed?

    egaistek

    September 13, 2008 at 10:04

  5. Hi Egaistek,

    The version is 8.04.1 , I checked for the drivers in sony website for VGN-FW170J it does not have any other drivers except vista.

    The XP is not installing either coz the sony support say they dont support any other OS for their hardware , I think the corporates like sony are irresponsible on part of public we are at their mercy, imagine we pay 1500$ and cant install a software of our choice.

    Is their any way I can find out why Kubuntu is not loading?

    I will wait for long time and see .

    Thanks neway

    mak

    September 14, 2008 at 05:23

  6. Hi Mak,
    Dunno if you’ve got Kubuntu 8.04 running yet or not but I’m currently posting this comment from mine on a SR series (SR16GN) Vaio (asia-pacific branded version of the FW series northern hemisphere model) and ‘everything’ pretty much works. Just had a couple of freezes today (after a few weeks of use) and had to reboot – unsure what that is.
    If you need any more help let me know.
    -Tim

    Tim Knapp

    October 14, 2008 at 10:15

  7. SR series is not exactly as FW, SR is smaller (not 16 inch) and may have different hardware and different display.

    Does brightness control work in on your’s laptop, Tim?

    egaistek

    October 14, 2008 at 10:30


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: